Network Upgrade

Scheduled for May 15, 11:00 - 13:00 BST

Update

Scheduled maintenance will start tomorrow, estimated time: 8 AM-1 PM
Posted Jun 11, 2026 - 13:22 BST

Update

Upgrade date has been rescheduled to the 12th of June 2026, We apologize for the long delay, We are trying to resolve this with Sky as soon as possible.
Posted Jun 06, 2026 - 17:24 BST

Update

Engineer never arrived within time slot, Maintenance will remain delayed until further notice, ETA is currently unknown.
Posted May 15, 2026 - 18:19 BST

Update

Engineer failed to arrive, Maintenance is now delayed until further notice.
Posted May 15, 2026 - 13:09 BST

Update

Scheduled maintenance will start tomorrow, estimated time: 8 AM-1 PM
Posted May 14, 2026 - 23:30 BST

Update

Waiting for Engineer. Confirmed date: 15th May
Posted May 10, 2026 - 23:43 BST

Scheduled

The Network will go offline to upgrade to Fiber networking, The Minecraft Server will be unreachable until the upgrade is complete.
Posted May 03, 2026 - 15:05 BST
This scheduled maintenance affects: LucaSMP (Bedrock, Java, Proximity Voicechat, Voting System, ImageFrame, Map, Minecraft Server, Storage-Server-1, Netgear Ethernet Switch, TP-Link Router, Sky Router).