Partial Server Outage

Incident Report for LucaSMP

Update

We are continuing to work on a fix for this issue.
Posted Mar 23, 2026 - 19:13 GMT

Update

We are continuing to work on a fix for this issue.
Posted Mar 18, 2026 - 15:46 GMT

Identified

Plugins like Simple Voice Chat, the Voting system, and support for Bedrock Edition is temporarily unavailable due to the addition of a DDoS protection service, The Website is also affected by this too. There is currently no ETA of fix because i need to get a job first before i can upgrade the protection to also include Bedrock (Geyser) and the ports needed for the Website, the Voting system, and Simple Voice Chat, i am working as fast as possible to fix these issues as soon as possible. As of now the server is currently joinable with the new protections added but the features listed above are temporarily unavailable until further notices. Please do not report any issues regarding the Voting system not working for example.
Posted Mar 10, 2026 - 15:35 GMT
This incident affects: LucaSMP (Bedrock, Proximity Voicechat, Voting System, ImageFrame, Map, Minecraft Server).