Verification is currently underway for the maintenance items.
Posted Jun 01, 2026 - 22:35 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2026 - 21:04 BST
Scheduled
To make up for the Fibre Upgrade delay, We have decided to upgrade our network to fully use ethernet, This is just the first half of the upgrade (Upgrading the switch), After the Fibre has been installed, We will install an ethernet cable that bypasses the TP-Link Router (Which is i wireless link, not ethernet) and will connect the Ethernet Switch directly to the Sky Router with ethernet. The TP-Link Router will be recycled and will be used as a personal wireless access point. Bypassing the TP-Link router will result in a more stable wired connection to the Sky Router, And better connection to the Minecraft Server. (Disclaimer: The time set in this maintenance report is currently not final, This will be confirmed on the day the maintenance begins.)